summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:59 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:23 +0200
commit849f31d5746f5633f9f2a768b76739afc257ae99 (patch)
tree831c3159be5f6022c2e419ed71a36cf6119af27f /gnu/packages/games.scm
parent6a37e77bd31cbf9762ada9afb1e1140a45655d96 (diff)
gnu: Add Plunder.
* gnu/packages/games.scm (plunder): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7e36c66b6a..cc4ca0c3e1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022, 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
-;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2022, 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
@@ -155,6 +155,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
@@ -223,6 +224,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
+ #:use-module (guix build-system haskell)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -11340,6 +11342,45 @@ original, they have been invented by Thomas Colcombet.")
(home-page "https://www.gnu.org/software/liquidwar6/")
(license license:gpl3+)))
+(define-public plunder
+ (let ((commit "026ded7083df5134bdf05b1ec7e5a0099ac9b9d2")
+ (revision "1"))
+ (package
+ (name "plunder")
+ (version (git-version "1.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jappeace/plunder")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m0v8x6q9iq4zihwmysbxjwkq18nar6xhq4g18p2g8c6azj2mgd6"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-monadrandom
+ ghc-quickcheck
+ ghc-file-embed
+ ghc-generic-lens
+ ghc-lens
+ ghc-random
+ ghc-reflex
+ ghc-reflex-sdl2
+ ghc-sdl2
+ ghc-sdl2-gfx
+ ghc-sdl2-image
+ ghc-sdl2-ttf
+ ghc-vector
+ ghc-witherable))
+ (native-inputs (list ghc-hspec ghc-hspec-core hspec-discover))
+ (home-page "https://github.com/jappeace/plunder")
+ (synopsis "Game about looting a hexagonal-tile world")
+ (description
+ "This package provides a work-in-progress game where you control a
+Viking and your objective is to loot all of the occupied hexagonal tiles in
+the map.")
+ (license license:expat))))
+
(define-public freerct
(package
(name "freerct")