summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-04-17 22:50:47 +0200
committerJulien Lepiller <julien@lepiller.eu>2023-04-18 21:49:03 +0200
commitba203839a5cb623fd778eeffc4dcea8d077a9603 (patch)
tree772bf4344faca7d28d46acbb1855169c8a234bcd /gnu/packages/games.scm
parentd86869428c8a84fbaf7c59e6ea5e2a1d85f8e254 (diff)
gnu: openttd-opengfx: Fix build.
* gnu/packages/games.scm (openttd-opengfx)[arguments]: Create mime database in the `configure` phase. [native-inputs]: Add shared-mime-info.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0fba4f5ce9..c63436ccd9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4469,6 +4469,11 @@ engine. When you start it you will be prompted to download a graphics set.")
;; Make sure HOME is writable for GIMP.
(setenv "HOME" (getcwd))
+ (mkdir-p ".local/share")
+ (symlink (string-append #$(this-package-native-input "shared-mime-info")
+ "/share/mime")
+ ".local/share/mime")
+
;; Redirect stdout, not stderr, to /dev/null. This prevents
;; dos2unix from receiving its version information as a flag.
(substitute* "Makefile"
@@ -4483,6 +4488,7 @@ engine. When you start it you will be prompted to download a graphics set.")
#:parallel-build? #f))
(native-inputs
(list dos2unix
+ shared-mime-info
gimp
grfcodec
nml