summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:00 +0200
commitd21ddfc9d884f045afa6db581e852c525c67ef35 (patch)
tree007f9d640a89a2b542397b1a625935953ac7f90b /gnu/packages/games.scm
parent33ae2fb39824fbcdbd8f39a7a2936d3186df4513 (diff)
gnu: xonotic-data: Don't copy 1.2-GiB file to build directory.
* gnu/packages/games.scm (xonotic-data)[arguments]: Extract SOURCE directly from the store.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 055c9ba9b7..19bc495b00 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7779,8 +7779,7 @@ quotation from a collection of quotes.")
(xonotic (string-append out "/share/xonotic"))
(source (assoc-ref %build-inputs "source"))
(unzip (search-input-file %build-inputs "/bin/unzip")))
- (copy-file source (string-append #$name "-" #$version ".zip"))
- (invoke unzip (string-append #$name "-" #$version ".zip"))
+ (invoke unzip source)
(chdir "Xonotic")
(install-file "key_0.d0pk" xonotic)
(copy-recursively "data"