summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorIvana Drazovic <iv.dra@hotmail.com>2023-04-19 21:53:54 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-11 16:38:28 +0200
commit420b6a85558204f3261d81e443e0c2c81e9c790b (patch)
treed31eeeca18974e4bcf9310458c93cf603c89e167 /gnu/packages/games.scm
parent199218e372f490ae8158bac99d3a434557ef1bec (diff)
gnu: laby: Use new package style.
* gnu/packages/games.scm (laby)[arguments]: Use gexps. Use "this-package-input" to locate package input. Co-authored-by: Florian Pelz <pelzflorian@pelzflorian.de> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2e3994543a..58c09a5b3b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -76,6 +76,8 @@
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5903,17 +5905,17 @@ Linux / Mac OS X servers, and an auto mapper with a VT100 map display.")
(inputs
(list lablgtk3 ocaml-lablgtk3-sourceview3 ocaml ocaml-findlib ocamlbuild))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'set-library-path
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((lablgtk (assoc-ref inputs "lablgtk")))
- (setenv "LD_LIBRARY_PATH"
- (string-append lablgtk "/lib/ocaml/stublibs"))))))
- #:tests? #f ; no 'check' target
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")) "all")))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'set-library-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((lablgtk #$(this-package-input "lablgtk")))
+ (setenv "LD_LIBRARY_PATH"
+ (string-append lablgtk "/lib/ocaml/stublibs"))))))
+ #:tests? #f ; no 'check' target
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output) "all")))
(home-page "https://sgimenez.github.io/laby/")
(synopsis "Programming game")
(description "Learn programming, playing with ants and spider webs ;-)