summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-04 08:17:05 -0400
committerMark H Weaver <mhw@netris.org>2016-08-04 08:17:05 -0400
commit536fc5f8cd45023c3c6f28f9c768338b5e797b47 (patch)
tree8516410664ed4d6ff0f68b48e71e5ec866367c44 /gnu/packages/games.scm
parent0832787e5c463c713d8f24fdec0f52900ff1c2bd (diff)
parenta8cb87abe98d57fb763d5b14524dc32c96bd31b5 (diff)
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e79ab481bb..e467dbe04c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
@@ -20,7 +21,7 @@
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il"
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2370,9 +2371,9 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(perl (string-append (assoc-ref %build-inputs
"perl")
"/bin"))
- (gunzip (string-append (assoc-ref %build-inputs
+ (gzip (string-append (assoc-ref %build-inputs
"gzip")
- "/bin/gunzip"))
+ "/bin/gzip"))
(tar (string-append (assoc-ref %build-inputs
"tar")
"/bin/tar"))
@@ -2382,7 +2383,7 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
(begin
(mkdir out)
(copy-file tarball "grue-hunter.tar.gz")
- (zero? (system* gunzip "grue-hunter.tar.gz"))
+ (zero? (system* gzip "-d" "grue-hunter.tar.gz"))
(zero? (system* tar "xvf" "grue-hunter.tar"))
(mkdir-p bin)