summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-06-09 12:25:32 +0100
committerChristopher Baines <mail@cbaines.net>2018-06-09 12:25:32 +0100
commit5bf37e9c38d7804136fb91075581aac77c86bd87 (patch)
treec2eed4eebdc2d6ce7d8201859c83272180e81d2a /gnu/packages/games.scm
parentaa7587633b1d5bc53338f388cdf35babf3ffb67f (diff)
gnu: openttd: Add patch to fix compilation.
* gnu/packages/games.scm (openttd)[source]: Add a unreleased upstream patch to fix building OpenTTD with ICU 61.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5568de033b..c445154b69 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2001,6 +2001,16 @@ world}, @uref{http://evolonline.org, Evol Online} and
(origin (method url-fetch)
(uri (string-append "http://binaries.openttd.org/releases/"
version "/openttd-" version "-source.tar.xz"))
+ (patches
+ (list
+ (origin (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenTTD/OpenTTD/commit/"
+ "19076c24c1f3baf2a22d1fa832d5688216cf54a3.patch"))
+ (file-name "openttd-fix-compilation-with-ICU-61.patch")
+ (sha256
+ (base32
+ "02d1xmb75yv4x6rfnvxk3vvq4l3lvvwr2pfsdzn7lzalic51ziqh")))))
(sha256
(base32
"0dhv5bbbg1dmmq7fi3xss0a9jq2rqgb5sf9fsqzlsjcdm590j6b1"))