summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-10-04 20:34:48 +0300
committerAlex Kost <alezost@gmail.com>2015-10-13 13:29:11 +0300
commit2e2ed3cbf9f37f3b2da79cc36ddbca01f35ee08c (patch)
tree2ce8a145abc71d4d8925dda6e7ad361cd072c92f /gnu/packages/games.scm
parentb3e2a5af9ffa165b1131d5f5d6dec735d6a54c43 (diff)
gnu: Add manaplus.
* gnu/packages/games.scm (manaplus): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3f1f5a9c94..cbc147f975 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1105,3 +1106,41 @@ on the screen and keyboard to display letters.")
;; Most files under gpl2+ or gpl3+, but eat.wav under gpl3
(license license:gpl3)))
+(define-public manaplus
+ (package
+ (name "manaplus")
+ (version "1.5.9.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://repo.manaplus.org/manaplus/download/"
+ version "/manaplus-" version ".tar.xz"))
+ (sha256
+ (base32
+ "070ms1cv7q88284pqh66lfhacckgv7m9s8z9009k2laypibx7vs6"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "CPPFLAGS=-I"
+ (assoc-ref %build-inputs "sdl-union")
+ "/include/SDL"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glu" ,glu)
+ ("curl" ,curl)
+ ("libxml2" ,libxml2)
+ ("mesa" ,mesa)
+ ("physfs" ,physfs)
+ ("sdl-union" ,(sdl-union))))
+ (home-page "http://manaplus.org")
+ (synopsis "Client for 'The Mana World' and similar games")
+ (description
+ "ManaPlus is a 2D MMORPG client for game servers. It is the only
+fully supported client for @uref{http://www.themanaworld.org, The mana
+world}, @uref{http://evolonline.org, Evol Online} and
+@uref{http://landoffire.org, Land of fire}.")
+ ;; "src/debug/*" and "src/sdl2gfx/*" are under Zlib.
+ ;; "data/themes/{golden-delicious,jewelry}/*" are under CC-BY-SA.
+ ;; The rest is under GPL2+.
+ (license (list license:gpl2+ license:zlib license:cc-by-sa4.0))))