summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-10-10 10:45:04 +0300
committerAlex Kost <alezost@gmail.com>2015-10-13 13:29:11 +0300
commitaec05972cef03010a1ad7d1ec83780e215eb1215 (patch)
tree9ec17b51be2d33703a47c700421ecc369fe75488 /gnu/packages/games.scm
parent2e2ed3cbf9f37f3b2da79cc36ddbca01f35ee08c (diff)
gnu: abbaye: Use 'modify-phases'.
* gnu/packages/games.scm (abbaye)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm59
1 files changed, 29 insertions, 30 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cbc147f975..e250bf9633 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -161,36 +161,35 @@ scriptable with Guile.")
'(#:modules ((ice-9 match)
(guix build gnu-build-system)
(guix build utils))
- #:phases (alist-cons-after
- 'set-paths 'set-sdl-paths
- (lambda* (#:key inputs outputs (search-paths '()) #:allow-other-keys)
- (define input-directories
- (match inputs
- (((_ . dir) ...)
- dir)))
- ;; This package does not use pkg-config, so modify CPATH
- ;; variable to point to include/SDL for SDL header files.
- (set-path-environment-variable "CPATH"
- '("include/SDL")
- input-directories))
- (alist-cons-after
- 'patch-source-shebangs 'patch-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Replace /usr with package output directory.
- (for-each (lambda (file)
- (substitute* file
- (("/usr") (assoc-ref outputs "out"))))
- '("makefile" "src/pantallas.c" "src/comun.h")))
- (alist-cons-before
- 'install 'make-install-dirs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prefix (assoc-ref outputs "out")))
- ;; Create directories that the makefile assumes exist.
- (mkdir-p (string-append prefix "/bin"))
- (mkdir-p (string-append prefix "/share/applications"))
- (mkdir-p (string-append prefix "/share/pixmaps"))))
- ;; No configure script.
- (alist-delete 'configure %standard-phases))))
+ #:phases (modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-paths
+ (lambda* (#:key inputs outputs (search-paths '())
+ #:allow-other-keys)
+ (define input-directories
+ (match inputs
+ (((_ . dir) ...)
+ dir)))
+ ;; This package does not use pkg-config, so modify CPATH
+ ;; variable to point to include/SDL for SDL header files.
+ (set-path-environment-variable "CPATH"
+ '("include/SDL")
+ input-directories)))
+ (add-after 'patch-source-shebangs 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Replace /usr with package output directory.
+ (for-each (lambda (file)
+ (substitute* file
+ (("/usr") (assoc-ref outputs "out"))))
+ '("makefile" "src/pantallas.c" "src/comun.h"))))
+ (add-before 'install 'make-install-dirs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prefix (assoc-ref outputs "out")))
+ ;; Create directories that the makefile assumes exist.
+ (mkdir-p (string-append prefix "/bin"))
+ (mkdir-p (string-append prefix "/share/applications"))
+ (mkdir-p (string-append prefix "/share/pixmaps")))))
+ ;; No configure script.
+ (delete 'configure))
#:tests? #f)) ;; No check target.
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("sdl" ,sdl)