summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 21:57:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 21:57:38 +0100
commit369a91d9317374d107b509bfe83456e5ce83b1f8 (patch)
treebc02e02bf161d342d0b8c011e69c93fe5320cd3f /gnu/packages/games.scm
parentdb2badeb91fd7270fe84600858064a360691c223 (diff)
gnu: openttd-engine: Use INVOKE.
* gnu/packages/games.scm (openttd-engine)[arguments]: Use INVOKE in configure phase.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5aa8fe6604..edd7a1dc0f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2346,15 +2346,14 @@ world}, @uref{http://evolonline.org, Evol Online} and
#:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(lzo (assoc-ref inputs "lzo")))
- (zero?
- (apply system* "./configure"
- (string-append "--prefix=" out)
- ;; Provide the "lzo" path.
- (string-append "--with-liblzo2="
- lzo "/lib/liblzo2.a")
- ;; Put the binary in 'bin' instead of 'games'.
- "--binary-dir=bin"
- configure-flags))))))))
+ (apply invoke "./configure"
+ (string-append "--prefix=" out)
+ ;; Provide the "lzo" path.
+ (string-append "--with-liblzo2="
+ lzo "/lib/liblzo2.a")
+ ;; Put the binary in 'bin' instead of 'games'.
+ "--binary-dir=bin"
+ configure-flags)))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("allegro" ,allegro)