summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-02-22 20:13:15 +0100
committerJohn Darrington <jmd@gnu.org>2017-02-23 21:25:08 +0100
commita20b084a0437e6832e3fbee58b23a789e510654c (patch)
tree4dff830775c2601a9d3f0c3c339d0c5adbcd1b45 /gnu/packages/games.scm
parent1d311009fe34a7b22814cc6a3386375ff9142d51 (diff)
gnu: Add gnushogi and xshogi
* gnu/packages/games.scm (gnushogi, xshogi): New variables.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1d6a12a0f6..50315a6085 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -175,6 +175,49 @@ You may even apply photos to the faces instead of colors. The game is
scriptable with Guile.")
(license license:gpl3+)))
+(define-public gnushogi
+ (package
+ (name "gnushogi")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnushogi/gnushogi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0a9bsl2nbnb138lq0h14jfc5xvz7hpb2bcsj4mjn6g1hcsl4ik0y"))))
+ (arguments `(#:tests? #f)) ;; No check target.
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/gnushogi/")
+ (synopsis "The game of Shogi (Japanese chess)")
+ (description "GNU Shogi is a program that plays the game Shogi (Japanese
+Chess). It is similar to standard chess but this variant is far more complicated.")
+ (license license:gpl3+)))
+
+(define-public xshogi
+ (package
+ (name "xshogi")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnushogi/xshogi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1dns0nhymak44by18sv48m4xb2skiwbi2i3nb9hl6w9iwd2i2brf"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libxaw" ,libxaw)
+ ("libxt" ,libxt)))
+ (home-page "http://www.gnu.org/software/gnushogi/")
+ (synopsis "User interface for @code{gnushogi}")
+ (description "A graphical user interface for the package @code{gnushogi}.")
+ ;; Contains a copy of GPLv3 but the licence notices simply
+ ;; state "GNU General Public Licence" without specifying a version.
+ (license license:gpl1+)))
+
(define-public abbaye
(package
(name "abbaye")