summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-29 18:46:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-29 22:05:59 +0200
commitddce090306023c7cf08eda81545b702f5fc1496d (patch)
tree042ebe8046c93be1f5a7d79570ad357a103e67f9 /gnu/packages/games.scm
parentdbaca6b5072c5954c248050243a0a1ca43c45f19 (diff)
gnu: games: Use INSTALL-FILE.
* gnu/packages/games.scm (glkterm, glulxe): Use INSTALL-FILE, return #t instead of an undefined value, and prefer using let bindings.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0dcb15f32b..80c5cc303e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -982,14 +983,16 @@ in different ways.")
'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (inc (string-append out "/include")))
+ (inc (string-append out "/include"))
+ (lib (string-append out "/lib")))
(mkdir-p inc)
(for-each
(lambda (file)
- (copy-file file (string-append inc "/" file)))
+ (install-file file inc))
'("glk.h" "glkstart.h" "gi_blorb.h" "gi_dispa.h" "Make.glkterm"))
- (mkdir (string-append out "/lib"))
- (copy-file "libglkterm.a" (string-append out "/lib/libglkterm.a"))))
+ (mkdir-p lib)
+ (install-file "libglkterm.a" lib))
+ #t)
(alist-delete 'configure %standard-phases))))
(home-page "http://www.eblong.com/zarf/glk/")
(synopsis "Curses Implementation of the Glk API")
@@ -1026,9 +1029,11 @@ using the curses.h library for screen control.")
(alist-replace
'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
(mkdir-p bin)
- (copy-file "glulxe" (string-append bin "/glulxe"))))
+ (install-file "glulxe" bin))
+ #t)
(alist-delete 'configure %standard-phases))))
(home-page "http://www.eblong.com/zarf/glulx/")
(synopsis "Interpreter for Glulx VM")