summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-06-06 09:59:15 +0200
committerRutger Helling <rhelling@mykolab.com>2018-06-06 16:48:47 +0200
commite6fcf903ec6442e798e623bc70661372160a8e2a (patch)
tree9cfd40dd4833cb365d5e72112ddecdecc6843f0d /gnu/packages/games.scm
parent7ea56cdec0f733b2c1bd33699505e9309a9f90bc (diff)
gnu: vulkan-loader: Update URL and change name.
* gnu/packages/emulators.scm: Change references from 'vulkan-icd-loader' to 'vulkan-loader'. * gnu/packages/games.scm: Change references from 'vulkan-icd-loader' to 'vulkan-loader'. * gnu/packages/video.scm: Change references from 'vulkan-icd-loader' to 'vulkan-loader'. * gnu/packages/vulkan.scm (vulkan-loader): Rename from 'vulkan-icd-loader' to 'vulkan-loader'. Update URL and hash. * gnu/packages/wine.scm: Change references from 'vulkan-icd-loader' to 'vulkan-loader'.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9408925514..e9f3e69f34 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4467,7 +4467,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(arguments
`(#:make-flags
(let ((vulkanlib (string-append (assoc-ref %build-inputs
- "vulkan-icd-loader") "/lib")))
+ "vulkan-loader") "/lib")))
(list "CC=gcc"
"MP3LIB=mpg123"
"USE_CODEC_FLAC=1"
@@ -4480,7 +4480,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(add-after 'unpack 'fix-makefile-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((vulkan (assoc-ref %build-inputs
- "vulkan-icd-loader"))
+ "vulkan-loader"))
(out (assoc-ref outputs "out")))
(mkdir-p (string-append out "/bin"))
(substitute* "Quake/Makefile" ((" /usr")
@@ -4491,7 +4491,7 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
#t))))
,@(strip-keyword-arguments '(#:make-flags #:phases)
(package-arguments quakespasm))))
- (inputs `(("vulkan-icd-loader" ,vulkan-icd-loader)
+ (inputs `(("vulkan-loader" ,vulkan-loader)
,@(package-inputs quakespasm)))
(description "vkquake is a modern engine for id software's Quake 1.
It includes support for 64 bit CPUs, custom music playback, a new sound driver,