summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJakob Kirsch <jakob.kirsch@web.de>2023-05-17 20:52:00 +0200
committerLudovic Courtès <ludo@gnu.org>2023-06-08 23:07:59 +0200
commit42ea60b7dddf67bb1c3792cbe943b5c4d318733d (patch)
treeda9afd50000eb1cd27997d7b580c9a7052f9e428 /gnu/packages/games.scm
parent8f855dd187b6a38a88d12f7af5d55ccfa8ee37b0 (diff)
gnu: Add rogue.
* gnu/packages/games.scm (rogue): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 862aa26805..8c00c2e66e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -877,6 +877,31 @@ Quizzes: arithmetic and quiz.")
;; phantasia (all but phantasia/pathnames.h.in, which is bsd-3)
(license:fsf-free "file:///phantasia/COPYRIGHT")))))
+(define-public rogue
+ (package
+ (name "rogue")
+ (version "5.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Davidslv/rogue")
+ (commit "cf9bd26d564a72fac4cf56b55c96c2435270d29a")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mk03l120scas4dcn6xccnhslnwmcx2blshbf925z06yk7rkzias"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list "CFLAGS=-DNCURSES_INTERNALS")))
+ (inputs (list ncurses))
+ (synopsis "Original rogue game")
+ (description
+ "This package provides ``Rogue: Exploring the Dungeons of Doom'', the
+original rogue game found on 4.2BSD.")
+ (home-page "https://github.com/Davidslv/rogue")
+ (license license:bsd-3)))
+
(define-public bzflag
(package