summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-03-20 14:54:26 +0000
committerChristopher Baines <mail@cbaines.net>2024-03-20 14:54:26 +0000
commit8fa07612644339a2bf21be9ee924e6ff1e0ec81d (patch)
treedbcb73053fac420077d45b20d9460134818ad2be /gnu/packages/games.scm
parentebe30c375495e7232551b32b6771f3c06a676f41 (diff)
parent69951a61a1d8f1f2135ea2dc836738be282b97bc (diff)
Merge remote-tracking branch 'savannah/master' into gnome-team
Change-Id: Iec8e15b79c6fde516294c2bfcaf8ee3575b1f745
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm48
1 files changed, 43 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e619c2f10e..f150c33e83 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -938,6 +938,41 @@ original rogue game found on 4.2BSD.")
(home-page "https://github.com/Davidslv/rogue")
(license license:bsd-3)))
+(define-public sgt-puzzles
+ (let ((commit "80aac3104096aee4057b675c53ece8e60793aa90")
+ (revision "0"))
+ (package
+ (name "sgt-puzzles")
+ (version (git-version "20240302" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.tartarus.org/simon/puzzles.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z4clv0xi98q28riz323ppn165cm62gj1c6h3xdd2sym4v8gy65z"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No tests.
+ #:configure-flags #~(list "-DNAME_PREFIX=sgt-")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-xdg-open-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "gtk.c"
+ (("(#define HELP_BROWSER_PATH).+" all define)
+ (format #f "~a ~s~%" define
+ (search-input-file inputs "/bin/xdg-open")))))))))
+ (inputs (list gtk+ xdg-utils))
+ (native-inputs (list pkg-config perl imagemagick halibut))
+ (home-page "https://www.chiark.greenend.org.uk/~sgtatham/puzzles/")
+ (synopsis "Simon Tatham's portable puzzle collection")
+ (description "Simon Tatham's Portable Puzzle Collection contains a number of
+popular puzzle games for one player.")
+ (license license:expat))))
(define-public bzflag
(package
@@ -7423,7 +7458,7 @@ at their peak of economic growth and military prowess.
(define-public open-adventure
(package
(name "open-adventure")
- (version "1.16")
+ (version "1.18")
(source
(origin
(method git-fetch)
@@ -7432,7 +7467,7 @@ at their peak of economic growth and military prowess.
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0spciwqcyldalzdd813zwigbldcnyaxi7kfslq1yp0fg4c4a10aa"))))
+ (base32 "1zl72lsp443aryzmwzh5w4j439jgf5njvh9xig6vjvmzhfcjkk9q"))))
(build-system gnu-build-system)
(arguments
(list
@@ -7461,10 +7496,13 @@ at their peak of economic growth and military prowess.
(install-file "advent.6" man)))))))
(native-inputs
(list asciidoc
+ cppcheck
libedit
pkg-config
+ python-pylint
python-pyyaml
- python-wrapper))
+ python-wrapper
+ ruby-asciidoctor))
(home-page "https://gitlab.com/esr/open-adventure")
(synopsis "Colossal Cave Adventure")
(description
@@ -8449,7 +8487,7 @@ ncurses for text display.")
(define-public naev
(package
(name "naev")
- (version "0.10.4")
+ (version "0.11.4")
(source
(origin
(method git-fetch)
@@ -8459,7 +8497,7 @@ ncurses for text display.")
(recursive? #t))) ; for game data
(file-name (git-file-name name version))
(sha256
- (base32 "0lg8cmzdzzpmqgmh9a1v190vv4d15hwa0inyzdwsq5x8lyc13hyr"))))
+ (base32 "1gd7jgb996fgnlrlqkfyx416g1kd458vik3nviazwwj83ksafaqb"))))
(build-system meson-build-system)
(arguments
;; XXX: Do not add debugging symbols, which cause the build to fail.