summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-08-21 10:29:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-08-21 12:16:45 +0200
commitae4da4c81f482d87bb6c40ba8862266ace79f9d3 (patch)
tree6487993a5aa8775ac1fc48a83f1e4a88ac7fe445 /gnu/packages/games.scm
parentb797e6906bb3d3a6bc49d97a2482994f28cf9eb7 (diff)
gnu: cdogs-sdl: Patch assets directory.
* gnu/packages/games.scm (cdogs-sdl)[arguments]: Add phase 'patch-install-directory to ensure data files are installed there.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8f8eca29de..d56c4ad5e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6523,7 +6523,15 @@ emerges from a sewer hole and pulls her below ground.")
(list
#:configure-flags
#~(list (string-append "-DCDOGS_DATA_DIR=" #$output
- "/share/cdogs-sdl/"))))
+ "/share/cdogs-sdl/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-install-directory
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set\\(DATA_INSTALL_DIR \".\"\\)")
+ (string-append "set(DATA_INSTALL_DIR \""
+ #$output "/share/cdogs-sdl\")"))))))))
(native-inputs
(list pkg-config))
(inputs