summaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-07-04 04:59:33 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-08 17:36:38 +0200
commit1fed71ce1976db9edf95fc4b99cac75a281fb526 (patch)
treec60fe1ab6800d96e78422463cf8e4e5d4b8647c1 /gnu/packages/gawk.scm
parent2e5c519b3f5d12b41132d535164fa04801f1bd4e (diff)
gnu: Add egawk-next.
* gnu/packages/gawk.scm (egawk-next): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 52ac66f9bb..6b905f6654 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public gawk
@@ -105,6 +106,34 @@ including network access, sorting, and large libraries.")
(modify-inputs (package-inputs gawk)
(prepend mpfr)))))
+;; Suffixed with -next because, similarly to Emacs, development versions are
+;; numbered x.y.60+z, and also there are no tagged versions of egawk yet.
+;; (However, though egawk's --version lists 5.1.60, it is actually forked from
+;; a development version of gawk 5.1.1.)
+(define-public egawk-next
+ (let ((commit "f00e74ffc73f6ba6fe74fb7a26319770b8c3792c")
+ (revision "0"))
+ (package
+ (inherit gawk-mpfr)
+ (name "egawk-next")
+ (version (git-version "5.1.60" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://www.kylheku.com/git/egawk")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bmfbw6k1aiyiardnk7ha5zlpkvavj013mm4n7wwj2vdcgrs6p1f"))))
+ (home-page "https://www.kylheku.com/cgit/egawk/")
+ (synopsis "Enhanced GNU Awk")
+ (description
+ "@command{egawk} is Enhanced GNU Awk. It is a fork of GNU Awk with
+some enhancements designed and implemented by Kaz Kylheku. In particular,
+Enhanced GNU Awk provides the @code{@@let} statement for declaring
+block-scoped lexical variables."))))
+
(define-public mawk
(package
(name "mawk")