summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-01 14:35:16 +0100
committerChristopher Baines <mail@cbaines.net>2024-06-26 17:17:51 +0100
commit48892222c43e164cd553f0a96fffe434afee8de3 (patch)
treebc7c5aca928b9125c3d3e97af0e5924628fc2265 /gnu/packages/gcc.scm
parente4617cd92d066668221d141dde46fbe037a438be (diff)
gnu: gcc: Simplify application of Hurd-specific pthread patch.
* gnu/packages/gcc.scm (gcc-11): Apply gcc-11-libstdc++-hurd-libpthread.patch unconditionally. (gcc-12): Also apply gcc-11-libstdc++-hurd-libpthread.patch. Change-Id: I80e2b2adb5636e1bff4536c5a0a348955454e81d
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 6bb564cab3..62df122f89 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -741,21 +741,10 @@ It also includes runtime support libraries for these languages.")
(base32
"1ncd7akww0hl5kkmw1dj3qgqp3phdrr5dfnm7jia9s07n0ib4b9z"))
(patches (search-patches "gcc-9-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"))
+ "gcc-5.0-libvtv-runpath.patch"
+ "gcc-11-libstdc++-hurd-libpthread.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
- (arguments
- (substitute-keyword-arguments (package-arguments gcc-8)
- ((#:phases phases #~%standard-phases)
- (if (target-hurd?)
- #~(modify-phases #$phases
- (add-after 'unpack 'patch-hurd-libpthread
- (lambda _
- (define patch
- #$(local-file
- (search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
- (invoke "patch" "--force" "-p1" "-i" patch))))
- phases))))
(properties
`((compiler-cpu-architectures
("aarch64" ,@%gcc-11-aarch64-micro-architectures)
@@ -777,7 +766,8 @@ It also includes runtime support libraries for these languages.")
(base32
"0fwcvbgpmjdfj5drfs8k6bkqsmxmz8pv4cmmjcd451p7k57mv6ll"))
(patches (search-patches "gcc-12-strmov-store-file-names.patch"
- "gcc-5.0-libvtv-runpath.patch"))
+ "gcc-5.0-libvtv-runpath.patch"
+ "gcc-11-libstdc++-hurd-libpthread.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
(properties