summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-19 13:17:08 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-19 13:52:11 +0100
commit5fec94f3a3d4c67b748f11847064ed60d67c5ade (patch)
tree9f2c7a21ad8f2c061a8d46aac817e4c68d307086 /gnu/packages/gcc.scm
parent6931ca9baaaee4c7e85cf3cd5d0f7e4eb5cfd88e (diff)
parent949f97f7f98ac74306b9de79c93790337d804e32 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Change-Id: I4f15bcb3e575062c4dd3b6c07a48470300413f24 Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/dictionaries.scm gnu/packages/display-managers.scm gnu/packages/engineering.scm gnu/packages/geo.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/gnome-xyz.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/mail.scm gnu/packages/patches/eudev-rules-directory.patch gnu/packages/plotutils.scm gnu/packages/sdl.scm gnu/packages/syndication.scm
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 863b8c76b2..963e9862fa 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -982,10 +982,18 @@ using compilers other than GCC."
(if (and (target-ppc64le?)
(version>=? version "11")
(not (version>=? version "12")))
- #~((add-after 'unpack 'patch-powerpc
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "patch" "--force" "-p1" "-i"
- (assoc-ref inputs "powerpc64le-patch")))))
+ ;; TODO: Drop the 'else' branch below on next rebuild
+ ;; cycle.
+ (if (%current-target-system)
+ #~((add-after 'unpack 'patch-powerpc ;correct
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (invoke "patch" "--force" "-p1" "-i"
+ (assoc-ref (or native-inputs inputs)
+ "powerpc64le-patch")))))
+ #~((add-after 'unpack 'patch-powerpc ;wrong
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "patch" "--force" "-p1" "-i"
+ (assoc-ref inputs "powerpc64le-patch"))))))
'()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-after 'unpack 'fix-rs6000-libdir