summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-30 12:10:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-30 13:58:37 +0300
commit86cab5c4bc436e1900bbc697eb12fbc177df24d6 (patch)
treed8890c7995afbe61d63db90c143b5c4381a53098 /gnu/packages/gcc.scm
parentfce707186af8be1dccd46fdf609649e5dc2b9d23 (diff)
gnu: gccgo-12: Fix building on riscv64-linux.
* gnu/packages/gcc.scm (make-gccgo)[arguments]: When building gccgo-12 for riscv64-linux don't add a phase to adjust the order of libgo dependencies. Change-Id: I600c744ce33ad802a5c466c19df41dcbb29a2be0
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c08c6521d6..0060ff7518 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1214,7 +1214,12 @@ provides the GNU compiler for the Go programming language.")
(substitute-keyword-arguments (package-arguments gccgo)
((#:phases phases)
#~(modify-phases #$phases
- #$@(if (version>=? (package-version gccgo) "12.0")
+ #$@(if (and (version>=? (package-version gccgo) "12.0")
+ ;; This somehow breaks gccgo@12 on riscv64-linux.
+ (not (and (target-riscv64?)
+ (string=? (version-prefix
+ (package-version gccgo) 1)
+ "12"))))
#~((add-after 'unpack 'adjust-libgo-dependencies
(lambda _
(substitute* "Makefile.in"