summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 17:09:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 17:09:53 -0400
commitd3a0869e9b667d563e7e877c93f30a70896c5831 (patch)
tree15460b434f44cf76916947ed2afbe848c43311d2 /gnu/packages/gcc.scm
parent70b0f2b9134b2db286f707835394798de039c277 (diff)
parent5694352c05ed4fdb57a9843d8f023ca3d85992c3 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bad96759f0..8bdee66459 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -617,7 +617,7 @@ Go. It also includes runtime support libraries for these languages.")
"btver1" "btver2" ;AMD
;; psABI micro-architecture levels
- "x86_64-v1" "x86_64-v2" "x86_64-v3" "x86_64-v4")))
+ "x86-64-v1" "x86-64-v2" "x86-64-v3" "x86-64-v4")))
;; Suitable '-march' values for GCC 12.
(define %gcc-12-aarch64-micro-architectures
@@ -783,6 +783,28 @@ It also includes runtime support libraries for these languages.")
("x86_64" ,@%gcc-12-x86_64-micro-architectures))
,@(package-properties gcc-11)))))
+(define-public gcc-13
+ (package
+ (inherit gcc-11)
+ (version "13.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1nj3qyswcgc650sl3h0480a171ixp33ca13zl90p61m689jffxg2"))
+ (patches (search-patches "gcc-12-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))
+ (modules '((guix build utils)))
+ (snippet gcc-canadian-cross-objdump-snippet)))
+ (properties
+ `((compiler-cpu-architectures
+ ("aarch64" ,@%gcc-13-aarch64-micro-architectures)
+ ("armhf" ,@%gcc-13-armhf-micro-architectures)
+ ("x86_64" ,@%gcc-13-x86_64-micro-architectures))
+ ,@(package-properties gcc-11)))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions.