summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-11 15:54:09 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-14 13:43:06 +0100
commitded8cdbe8959dc8a43ec63f81187f9dcfc0fd917 (patch)
tree3d816ed8149cc607271a5143329f91897cf89c14 /gnu/packages/gcc.scm
parent69d74e35b2ba516c3a17b91a46d27087e1c1068c (diff)
gnu: gcc: Change custom-gcc to use gexp's.
As this seems to be generating broken derivations for i586-gnu otherwise. * gnu/packages/gcc.scm (custom-gcc): Use gexp's for the generated package arguments.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 47fb443155..1db37529f7 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1043,18 +1043,18 @@ as the 'native-search-paths' field."
(srfi srfi-26)
(ice-9 regex)))
((#:configure-flags flags)
- `(cons (string-append "--enable-languages="
- ,(string-join languages ","))
- (remove (cut string-match "--enable-languages.*" <>)
- ,flags)))
+ #~(cons (string-append "--enable-languages="
+ #$(string-join languages ","))
+ (remove (cut string-match "--enable-languages.*" <>)
+ #$flags)))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'install 'remove-broken-or-conflicting-files
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each
- delete-file
- (find-files (string-append (assoc-ref outputs "out") "/bin")
- ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
+ #~(modify-phases #$phases
+ (add-after 'install 'remove-broken-or-conflicting-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ delete-file
+ (find-files (string-append (assoc-ref outputs "out") "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|lto)(-.*)?$"))))))))))
(define %generic-search-paths
;; This is the language-neutral search path for GCC. Entries in $CPATH are