summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-11 15:54:10 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-14 13:43:06 +0100
commit70986f052a2b60ccb5f3bd5da520f9cdf5ea60ad (patch)
tree8f54b772910bb14a4576d911dc616487de1521dd /gnu/packages/gcc.scm
parentded8cdbe8959dc8a43ec63f81187f9dcfc0fd917 (diff)
gnu: gcc: Change make-gccgo to use gexp's.
As otherwise this seems to generate broken derivations for i586-gnu. * gnu/packages/gcc.scm (make-gccgo): Use gexp's for the package arguments.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 1db37529f7..1b444c2b02 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1156,34 +1156,34 @@ provides the GNU compiler for the Go programming language.")
(arguments
(substitute-keyword-arguments (package-arguments gccgo)
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'install 'wrap-go-with-tool-path
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (exedir (string-append out "/libexec/gcc"))
- (tooldir (dirname (car (find-files exedir "^cgo$")))))
- (wrap-program (string-append out "/bin/go")
- `("GCCGOTOOLDIR" =
- (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
- `("GOROOT" =
- (,(string-append "${GOROOT:-" out "}")))))))
- (add-before 'configure 'fix-gotools-runpath
- (lambda _
- (substitute* "gotools/Makefile.in"
- (("AM_LDFLAGS =" all)
- (string-append all " -Wl,-rpath=$(libdir) ")))))
- (add-before 'configure 'remove-tool-reference-from-libgo
- (lambda _
- (substitute* "libgo/Makefile.in"
- (("(GccgoToolDir = \\\")[^\\\"]+" _ start)
- (string-append start "/nonexistent"))
- ,@(if (version>=? (package-version gccgo) "12.0")
- '((("(defaultGOROOT = `)[^`]+" _ start)
- (string-append start "/nonexistent")))
- '((("(DefaultGoroot = \\\")[^\\\"]+" _ start)
- (string-append start "/nonexistent"))))
- (("(defaultGOROOTValue.*?return `)[^`]+" _ start)
- (string-append start "/nonexistent"))))))))))))
+ #~(modify-phases #$phases
+ (add-after 'install 'wrap-go-with-tool-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (exedir (string-append out "/libexec/gcc"))
+ (tooldir (dirname (car (find-files exedir "^cgo$")))))
+ (wrap-program (string-append out "/bin/go")
+ `("GCCGOTOOLDIR" =
+ (,(string-append "${GCCGOTOOLDIR:-" tooldir "}")))
+ `("GOROOT" =
+ (,(string-append "${GOROOT:-" out "}")))))))
+ (add-before 'configure 'fix-gotools-runpath
+ (lambda _
+ (substitute* "gotools/Makefile.in"
+ (("AM_LDFLAGS =" all)
+ (string-append all " -Wl,-rpath=$(libdir) ")))))
+ (add-before 'configure 'remove-tool-reference-from-libgo
+ (lambda _
+ (substitute* "libgo/Makefile.in"
+ (("(GccgoToolDir = \\\")[^\\\"]+" _ start)
+ (string-append start "/nonexistent"))
+ #$@(if (version>=? (package-version gccgo) "12.0")
+ '((("(defaultGOROOT = `)[^`]+" _ start)
+ (string-append start "/nonexistent")))
+ '((("(DefaultGoroot = \\\")[^\\\"]+" _ start)
+ (string-append start "/nonexistent"))))
+ (("(defaultGOROOTValue.*?return `)[^`]+" _ start)
+ (string-append start "/nonexistent"))))))))))))
(define-public gccgo-4.9
(custom-gcc (package