summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/gd.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm46
1 files changed, 14 insertions, 32 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 169f040ee4..3b1def55e1 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -38,11 +38,10 @@
(define-public gd
(package
(name "gd")
- (replacement gd-2.2.5)
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.4")
+ (version "2.2.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -50,11 +49,9 @@
version "/libgd-" version ".tar.xz"))
(sha256
(base32
- "1rp4v7n1dq38b92kl7gkvpvqqkw7nvdfnz6d5kip5klkxfki6zqk"))
- (patches (search-patches "gd-fix-gd2-read-test.patch"
- "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"
- "gd-php-73968-Fix-109-XBM-reading.patch"))))
+ "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
+ (patches (search-patches "gd-fix-tests-on-i686.patch"
+ "gd-freetype-test-failure.patch"))))
(build-system gnu-build-system)
(arguments
;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
@@ -93,22 +90,6 @@ most common applications of GD involve website development.")
"See COPYING file in the distribution."))
(properties '((cpe-name . "libgd")))))
-;; For CVE-2017-6362 and CVE-2017-7890.
-(define-public gd-2.2.5
- (package
- (inherit gd)
- (version "2.2.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libgd/libgd/releases/download/gd-"
- version "/libgd-" version ".tar.xz"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"))
- (sha256
- (base32
- "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))))))
-
(define-public perl-gd
(package
(name "perl-gd")
@@ -141,15 +122,16 @@ most common applications of GD involve website development.")
(assoc-ref %build-inputs i)))
'("zlib" "png" "ft" "jpeg" "fontconfig"))
#:tests? #f ;; Failed 1/2 test programs. 1/12 subtests failed.
- #:phases (alist-cons-after
- 'configure 'clear-autogenerated-files
- (lambda _
- ;; This file is autogenerated by its .PLS script at build
- ;; time, but file creation fails because that file already
- ;; exists in the distribution with non-writable
- ;; permissions, so delete it first.
- (delete-file "bdf_scripts/bdf2gdfont.pl"))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'clear-autogenerated-files
+ (lambda _
+ ;; This file is autogenerated by its .PLS script at build
+ ;; time, but file creation fails because that file already
+ ;; exists in the distribution with non-writable
+ ;; permissions, so delete it first.
+ (delete-file "bdf_scripts/bdf2gdfont.pl")
+ #t)))))
(home-page "http://search.cpan.org/dist/GD")
(synopsis "Perl interface to the GD graphics library")
(description "GD.pm is an autoloadable interface module for libgd, a