summaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-07-26 17:02:16 +0000
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:29 +0200
commit2eb2501d66d4f0d40e77aac6b0a15d5872f5848b (patch)
tree91f568e8bdd825588771cdfa927e4a2b154a6c21 /gnu/packages/gdb.scm
parentbce64b41804432aea96ceb3e49b8b53de58a2d90 (diff)
gnu: Add gdb-12.
* gnu/packages/gdb.scm (gdb-12): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index aa9e479e46..7d8416c7c5 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -149,6 +149,18 @@ the program is running to try to fix bugs. It can be used to debug programs
written in C, C++, Ada, Objective-C, Pascal and more.")
(license gpl3+)))
+(define-public gdb-12
+ (package
+ (inherit gdb-11)
+ (version "12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gdb/gdb-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))))
+
(define-public gdb
;; This is the fixed version that packages depend on. Update it rarely
;; enough to avoid massive rebuilds.