summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-10 15:45:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:36 +0100
commit186aa138a67131a1655522b2ae34c751b9713276 (patch)
treef916e91983cc01383d0e66b50bd0a7da9380e4f6 /gnu/packages/geo.scm
parent0c6db478ec40237db69d751acf64441556183e23 (diff)
gnu: python-metpy: Update to 1.6.0.
* gnu/packages/geo.scm (python-metpy): Update to 1.6.0. [arguments]: Add phases 'fix-version-check and 'hide-imp-deprecation-warnings. [native-inputs]: Add python-packaging; remove python-shapely and python-cartopy. Change-Id: I4a46a5e60b1904699475608146f2a09aefc07624
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 3ec8d9f975..91d1358084 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1493,13 +1493,13 @@ to create databases that are optimized for rendering/tile/map-services.")
(define-public python-metpy
(package
(name "python-metpy")
- (version "1.5.1")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "MetPy" version))
(sha256
(base32
- "1is6rradl97k04hf27dhzla4y4j98hibran3rbz6xh226q1r9vmb"))))
+ "125nb1bmkqpdf19fq0mbbgzdjczn46lr9yqi7zgn6k62dzjm1gm7"))))
(build-system pyproject-build-system)
(arguments
;; Too many of the tests in the files below require online data.
@@ -1522,7 +1522,23 @@ to create databases that are optimized for rendering/tile/map-services.")
" and not test_zoom_xarray"
" and not test_parse_wpc_surface_bulletin"
" and not test_add_timestamp_xarray"
- " and not test_parse_wpc_surface_bulletin_highres"))))
+ " and not test_parse_wpc_surface_bulletin_highres"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'fix-version-check
+ (lambda _
+ (substitute* "src/metpy/testing.py"
+ (("^( +)match = pattern.*" m indent)
+ (string-append indent "\
+version_spec = re.sub('[()]', '', version_spec)\n" m)))))
+ ;; The deprecation warning from python-future's use of imp breaks the
+ ;; tests.
+ (add-after 'unpack 'hide-imp-deprecation-warnings
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("\"ignore:numpy.ndarray size changed:RuntimeWarning\"," m)
+ (string-append m "
+\"ignore:the imp module is deprecated\","))))))))
(propagated-inputs (list python-importlib-resources
python-matplotlib
python-numpy
@@ -1533,8 +1549,8 @@ to create databases that are optimized for rendering/tile/map-services.")
python-scipy
python-traitlets
python-xarray))
- (native-inputs (list python-cartopy python-netcdf4 python-pytest
- python-pytest-mpl python-shapely))
+ (native-inputs (list python-netcdf4 python-packaging python-pytest
+ python-pytest-mpl))
(home-page "https://github.com/Unidata/MetPy")
(synopsis "Collection of tools to deal with weather data")
(description "MetPy is a collection of tools in Python for reading,