summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-02-11 10:10:25 +0000
committerChristopher Baines <mail@cbaines.net>2023-02-13 18:18:08 +0000
commit54cd2049e862f460a6add2430230f2c9c109a52d (patch)
treef8cc2c4f8bac74035c1e5ff7442994235ad6c37c /gnu/packages/geo.scm
parent2106deb9f6f7d6efaa3e170a99e7172c222eda10 (diff)
gnu: osm2pgsql: Update to 1.8.0.
* gnu/packages/geo.scm (osm2pgsql): Update to 1.8.0. [arguments]: Remove -DEXTERNAL_RAPIDJSON configure-flag, since osm2pgsql 1.8.0 does not use rapidjson anymore. [inputs]: Remove rapidjson. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 097ced33e1..b9a617c009 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1415,7 +1415,7 @@ based on the Osmium library.")
(define-public osm2pgsql
(package
(name "osm2pgsql")
- (version "1.7.0")
+ (version "1.8.0")
(source
(origin
(method git-fetch)
@@ -1424,7 +1424,7 @@ based on the Osmium library.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "15fxr4xq7siy237763l7nswx7v0swr3qzs2h3zkjzgvajw4p6qii"))
+ (base32 "0ssz7ny4wx8dzl3027p37xc5h7m1aj6bzxzdc6g8fbp7q57ykvxz"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1435,8 +1435,7 @@ based on the Osmium library.")
#:configure-flags
(list "-DEXTERNAL_LIBOSMIUM=ON"
"-DEXTERNAL_PROTOZERO=ON"
- "-DEXTERNAL_FMT=ON"
- "-DEXTERNAL_RAPIDJSON=ON")))
+ "-DEXTERNAL_FMT=ON")))
(inputs
(list boost
bzip2
@@ -1447,7 +1446,6 @@ based on the Osmium library.")
postgresql
proj
protozero
- rapidjson
zlib))
(native-inputs
(list python python-psycopg2))