summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-04-02 17:45:48 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-12 10:55:36 +0200
commit81b2e5975dbefa891852d3030512e1181e109d26 (patch)
treeaf254be785f7d46058c736be378e9e1f73d383b4 /gnu/packages/geo.scm
parent3171ee7003682622e3c0db67c08e302090ca0f6f (diff)
gnu: python-rtree: Update to 1.0.1.
* gnu/packages/geo.scm (python-rtree): Update to 1.0.1. [build-system]: Use pyproject-build-system instead of python-build-system. [arguments]: Remove custom 'check phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 344ffae8fb..e046797a3f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1655,14 +1655,14 @@ persisted.
(define-public python-rtree
(package
(name "python-rtree")
- (version "1.0.0")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Rtree" version))
(sha256
- (base32 "10lnhf67c9pb0yisxdqmb52dy6lj1za1h9d4p69v0ihk2a138j6h"))))
- (build-system python-build-system)
+ (base32 "0aalh07fyf6vpr0a6zswnqvvrjhyic1zg6w4bl368fihkilj2892"))))
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1672,11 +1672,7 @@ persisted.
(substitute* "rtree/finder.py"
(("find_library\\(\"spatialindex_c\"\\)")
(string-append "\"" libspatialindex
- "/lib/libspatialindex_c.so\""))))))
- (replace 'check
- (lambda* (#:key outputs tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ "/lib/libspatialindex_c.so\"")))))))))
(native-inputs
(list python-numpy python-pytest python-wheel))
(inputs