summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-11 17:10:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:37 +0100
commitae42b55d859d9df6e6ae6c7cc0688d083503c291 (patch)
treeea9881ed98a4f460b92dcbb36a10afe82b8a56af /gnu/packages/geo.scm
parent53c65baa3d4590d78c7660369bac0e69d3804503 (diff)
gnu: python-geopandas: Update to 0.14.2.
* gnu/packages/geo.scm (python-geopandas): Update to 0.14.2. [arguments]: Disable test_pandas_kind tests. Change-Id: I2a49d6ef73a79b84751ce0225757a2b83019cd42
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 91d1358084..14e2d9f16b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -939,14 +939,14 @@ pyproj, Rtree, and Shapely.")
(define-public python-geopandas
(package
(name "python-geopandas")
- (version "0.13.2")
+ (version "0.14.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "geopandas" version))
(sha256
(base32
- "0s59jjk02l1zajz95n1c7fr3fyj44wzxn569q2y7f34042f6vdg5"))))
+ "1nycf79nzris058lz1fyg0byj874wxq33an3y74zvybnhdxxawbf"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -955,6 +955,8 @@ pyproj, Rtree, and Shapely.")
;; Test files are missing
"--ignore=geopandas/tests/test_overlay.py"
"--ignore=geopandas/io/tests/test_file.py"
+ ;; Number of open figures changed during test
+ "-k" "not test_pandas_kind"
;; Disable tests that require internet access.
"-m" "not web")))
(propagated-inputs