summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2023-09-17 15:39:37 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2023-09-21 17:26:11 +0200
commitf92bff51b4595bb61729328a3a149d4d02df8cd3 (patch)
tree5973ed54174672a47fb3631dbf2478ad99374721 /gnu/packages/geo.scm
parentef18fd58b45b27898d2e97d5d6f580ad33bf571b (diff)
gnu: osmium-tool: Update to 1.15.0.
* gnu/packages/geo.scm (osmium-tool): Update to 1.15.0. Reviewed-by: Bruno Victal <mirai@makinata.eu> Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c7ee877a1e..8ee3b1a7ec 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1567,26 +1567,23 @@ OpenStreetMap data.")
(define-public osmium-tool
(package
(name "osmium-tool")
- (version "1.14.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/osmcode/osmium-tool")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0zgyqyrs89vch0qnkh9m5xq079sr2wmydy5zz4l8xbysbjf6xry5"))
- (modules '((guix build utils)))
- (snippet
- ;; Remove bundled libraries.
- '(delete-file-recursively "include/rapidjson"))))
+ (version "1.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/osmcode/osmium-tool")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d90vz316xdl3c416nicgdw7ybw17l2125wgxglbzl7jaqngapy5"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove bundled libraries.
+ '(delete-file-recursively "include/rapidjson"))))
(build-system cmake-build-system)
- (inputs
- (list libosmium
- rapidjson))
- (native-inputs
- (list pandoc))
+ (inputs (list libosmium rapidjson))
+ (native-inputs (list pandoc))
(home-page "https://osmcode.org/osmium-tool/")
(synopsis "Osmium command-line tool")
(description "Command line tool for working with OpenStreetMap data