summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-04 16:47:13 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-07 13:41:57 +0100
commita042bfcd7eecb3499d42f143eff733b669f2bbe0 (patch)
treee576f05e8360e6177766cb885aa353934a82fa7e /gnu/packages/geo.scm
parente25fa3f6da65e0cd6ac0c2bf86265aecfbd15345 (diff)
gnu: libgeotiff: Fix build with proj 9.3.1.
* gnu/packages/geo.scm (libgeotiff): [source]: Add patches to fix build with proj 9.3.1. * gnu/local.mk: Add patch files. * gnu/packages/patches/libgeotiff-fix-tests-on-i386.patch: New file. * gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch: New file. * gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.1.patch: New file. Change-Id: I5f09e793698b0b137888faa0f595ef06850c6160 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5882271174..3171efa0dc 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -548,7 +548,11 @@ and driving.")
(method url-fetch)
(uri (string-append "http://download.osgeo.org/geotiff/libgeotiff/libgeotiff-"
version ".tar.gz"))
- (patches (search-patches "libgeotiff-fix-tests-with-proj-9.1.1.patch"))
+ (patches
+ (search-patches "libgeotiff-fix-tests-with-proj-9.1.1.patch"
+ "libgeotiff-fix-tests-with-proj-9.3.0.patch"
+ "libgeotiff-fix-tests-with-proj-9.3.1.patch"
+ "libgeotiff-fix-tests-on-i386.patch"))
(sha256
(base32 "1mjmgv48x51ppax5dnb6lq7z600czxll53bx6jbzqwd4m93i7aq5"))
(modules '((guix build utils)))