summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-19 09:38:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 22:31:18 +0000
commit39e6994081af7cd0d93698cb6748dd9b16166c57 (patch)
treef018d8fe43bb7fcbe785bc8759dac1cdcb67dec3 /gnu/packages/geo.scm
parentdf33198cc2966103ded46eb328d1e8360bbe051d (diff)
gnu: python-osmnx: Reformat with guix style.
* gnu/packages/geo.scm (python-osmnx): Reformat with guix style. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm55
1 files changed, 26 insertions, 29 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index fbc2905af5..53e765da7d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -980,7 +980,7 @@ require a spatial database such as PostGIS.")
(version "1.8.1")
(source
(origin
- ; Fetch from github as the pypi package is missing the tests dir.
+ ;; Fetch from github as the pypi package is missing the tests dir.
(method git-fetch)
(uri (git-reference
(url "https://github.com/gboeing/osmnx")
@@ -991,37 +991,34 @@ require a spatial database such as PostGIS.")
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags
- '(list "-k"
- (string-append
- ;; The following tests require network access.
- "not test_stats"
- " and not test_geocoder"
- " and not test_osm_xml"
- " and not test_elevation"
- " and not test_routing"
- " and not test_plots"
- " and not test_find_nearest"
- " and not test_api_endpoints"
- " and not test_graph_save_load"
- " and not test_graph_from_functions"
- " and not test_features"))))
- (propagated-inputs
- (list python-folium
- python-geopandas
- python-matplotlib
- python-networkx
- python-numpy
- python-pandas
- python-requests
- python-shapely))
- (native-inputs
- (list python-hatchling python-pytest))
+ #:test-flags '(list "-k"
+ (string-append
+ ;; The following tests require network access.
+ "not test_stats"
+ " and not test_geocoder"
+ " and not test_osm_xml"
+ " and not test_elevation"
+ " and not test_routing"
+ " and not test_plots"
+ " and not test_find_nearest"
+ " and not test_api_endpoints"
+ " and not test_graph_save_load"
+ " and not test_graph_from_functions"
+ " and not test_features"))))
+ (propagated-inputs (list python-folium
+ python-geopandas
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-pandas
+ python-requests
+ python-shapely))
+ (native-inputs (list python-hatchling python-pytest))
(home-page "https://github.com/gboeing/osmnx")
(synopsis
- "Retrieve, model, analyze, and visualize OpenStreetMap street networks")
+ "Retrieve, model, analyze, and visualize OpenStreetMap street networks")
(description
- "OSMnx is a Python library that lets you download geospatial data
+ "OSMnx is a Python library that lets you download geospatial data
from OpenStreetMap and model, project, visualize, and analyze real-world
street networks and any other geospatial geometries. You can download
and model walkable, drivable, or bikeable urban networks with a single