summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:01 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:08 +0300
commit53809e5f4bb369ae634e11531ef647ea2282b170 (patch)
treeff5b915fd413a674279f122a9e029cdef971ba7e /gnu/packages/geo.scm
parentbb38261b5d878ef93a72ca82bf8312767dde0d17 (diff)
gnu: Add h3.
* gnu/packages/geo.scm (h3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index cd56f50bf0..7b327a930d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2020, 2021, 2022, 2023 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021, 2023 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2021, 2022 Nikolay Korotkiy <sikmir@disroot.org>
@@ -227,6 +227,30 @@ data formats are GRIB 1/2, netCDF 3/4, SERVICE, EXTRA and IEG. There are more
than 600 operators available.")
(license license:bsd-3)))
+(define-public h3
+ (package
+ (name "h3")
+ (version "4.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uber/h3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x764xzna8ka6yhgv2y4hb158a61y3g9a6835qckqp7wfkpqvb7f"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")))
+ (home-page "https://h3geo.org/")
+ (synopsis "Hexagonal hierarchical geospatial indexing system")
+ (description "H3 is a geospatial indexing system using a hexagonal grid
+that can be (approximately) subdivided into finer and finer hexagonal grids,
+combining the benefits of a hexagonal grid with S2's hierarchical
+subdivisions.")
+ (license license:asl2.0)))
+
(define-public memphis
(package
(name "memphis")