summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-11-02 07:50:13 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-11-09 19:09:08 +0100
commit71d54f3ac451527d3c741bc1209f6b03329f8571 (patch)
treee4e7a2b8be96c265281fc47efb543c8560905d23 /gnu/packages/geo.scm
parentdd631a891ce9e5202121d613bb97535891271f94 (diff)
gnu: josm: Update to 18822.
* gnu/packages/geo.scm (josm): Update to 18822. [inputs]: Use new json implementation. [arguments]: Use openjdk11 to prevent warning at startup. Change-Id: I393e0ed765d1d0da7870595d2eccefae17836eb9
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index a33d446201..dbc8440141 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1940,7 +1940,7 @@ to the OSM opening hours specification.")
(define-public josm
(package
(name "josm")
- (version "18646")
+ (version "18822")
(source (origin
(method svn-fetch)
(uri (svn-reference
@@ -1949,7 +1949,7 @@ to the OSM opening hours specification.")
(recursive? #f)))
(sha256
(base32
- "0zr3p1i39wi0f29lgb3xrnv6lijrq5ia8jxn4wnq1yz0xdlbg98i"))
+ "0b4q6n3jbqrh7dsfmcf2g0xdd1wjj62sjq8lwvggvrpqlk1fyn1b"))
(file-name (string-append name "-" version "-checkout"))
(modules '((guix build utils)))
(snippet
@@ -1963,17 +1963,18 @@ to the OSM opening hours specification.")
(list java-commons-jcs
java-commons-compress
java-jmapviewer
- java-jsonp-api
- java-jsonp-impl ; runtime dependency
+ java-jakarta-json
java-jsr305
java-metadata-extractor
java-opening-hours-parser
java-openjfx-media
+ java-parsson ; runtime dependency
java-signpost-core
java-svg-salamander))
(arguments
`(#:tests? #f
#:jar-name "josm.jar"
+ #:jdk ,openjdk11
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'rm-build.xml