summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-24 10:14:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-24 10:14:02 +0300
commitb02e7504b0ad3a448125e12f7c832f24b2559550 (patch)
tree942953e5f83003f3f2ca1e50b2451114894fe670 /gnu/packages/geo.scm
parent24f18482d3d57a49f0711e0c42f1e0ef5c1549df (diff)
gnu: xygrib: Build with newer proj.
* gnu/packages/geo.scm (xygrib)[source]: Add upstream patch to build with newer version of proj. [inputs]: Replace proj-7 with proj. * gnu/packages/patches/xygrib-newer-proj.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index bff213d684..25805fe2e5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1651,10 +1651,11 @@ map display. Downloads map data from a number of websites, including
(url "https://github.com/opengribs/XyGrib")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (patches (search-patches "xygrib-fix-finding-data.patch"))
(sha256
(base32
"0xzsm8pr0zjk3f8j880fg5n82jyxn8xf1330qmmq1fqv7rsrg9ia"))
+ (patches (search-patches "xygrib-fix-finding-data.patch"
+ "xygrib-newer-proj.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1695,7 +1696,7 @@ map display. Downloads map data from a number of websites, including
libnova
libpng
openjpeg
- proj-7
+ proj
qtbase-5
zlib))
(native-search-paths