summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-12-20 17:01:41 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-12-20 17:50:26 +0100
commit25f702449c8683b3ec78b2e4a5728e700462e5a2 (patch)
treebc0d289b98f4d633af093e0939574173ce031c96 /gnu/packages/geo.scm
parent3c6f7b53cea7ea5dc8176fec02271bc3770d7fc1 (diff)
gnu: Merge gdal and python-gdal packages.
* gnu/packages/geo.scm (gdal)[inputs]: Add swig and zstd. [native-inputs]: Add python. [propagated-inputs]: Add python-numpy. (python-gdal): Remove variable. (qgis)[inputs]: Remove python-gdal. [arguments]: Disable a flaky test.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 8 insertions, 22 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 02259c2f6c..2185af7a98 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1097,9 +1097,14 @@ development.")
proj
qhull
sqlite
- zlib))
+ swig
+ zlib
+ zstd))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ python))
+ (propagated-inputs
+ (list python-numpy))
(home-page "https://gdal.org/")
(synopsis "Raster and vector geospatial data format library")
(description "GDAL is a translator library for raster and vector geospatial
@@ -1128,25 +1133,6 @@ utilities for data translation and processing.")
;; frmts/mrf/libLERC
license:asl2.0))))
-(define-public python-gdal
- (package (inherit gdal)
- (name "python-gdal")
- (build-system python-build-system)
- (arguments
- '(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'chdir
- (lambda _
- (chdir "swig/python")
- #t)))))
- (native-inputs '())
- (propagated-inputs
- (list python-numpy))
- (inputs
- (list gdal))
- (synopsis "GDAL (Geospatial Data Abstraction Library) python bindings")))
-
(define-public python-pyshp
(package
(name "python-pyshp")
@@ -2554,6 +2540,7 @@ growing set of geoscientific methods.")
"ProcessingQgisAlgorithmsTestPt2"
"ProcessingQgisAlgorithmsTestPt3"
"ProcessingQgisAlgorithmsTestPt4"
+ "ProcessingGdalAlgorithmsRasterTest"
"ProcessingGdalAlgorithmsVectorTest"
"ProcessingGrass7AlgorithmsImageryTest"
"ProcessingGrass7AlgorithmsRasterTestPt1"
@@ -2671,7 +2658,6 @@ growing set of geoscientific methods.")
python-chardet
python-dateutil
python-future
- python-gdal
python-jinja2
python-numpy
python-owslib