summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-04-02 17:45:49 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-04-12 10:56:59 +0200
commitd8d89ffb01dd629306b1c7c20763401a1e337568 (patch)
tree7a11841fc56120667bf792a61f0fbb526b6b916e /gnu/packages/geo.scm
parent81b2e5975dbefa891852d3030512e1181e109d26 (diff)
gnu: python-osmnx: Use pyproject-build-system.
* gnu/packages/geo.scm (python-osmnx)[build-system]: Use pyproject-build-system instead of python-build-system. [arguments]: Remove custom 'check phase. Instead define test-flags to disable network tests. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e046797a3f..76a42c4140 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -44,6 +44,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix gexp)
@@ -854,30 +855,24 @@ require a spatial database such as PostGIS.")
(file-name (git-file-name name version))
(sha256
(base32 "1n8qjn184p5a2s3j6x6iyc1i7p3l3xnbqqxm6ajwgwv6j5fw1d5a"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- ; TODO: Disable network tests
- (invoke "pytest" "tests"
- "-k"
- (string-append
- ;; The following tests require network access.
- "not test_geocode_to_gdf"
- " and not test_stats"
- " and not test_osm_xml"
- " and not test_elevation"
- " and not test_routing"
- " and not test_plots"
- " and not test_find_nearest"
- " and not test_api_endpoints"
- " and not test_graph_save_load"
- " and not test_graph_from_functions"
- " and not test_geometries"))))))))
+ (list
+ #:test-flags
+ '(list "-k"
+ (string-append
+ ;; The following tests require network access.
+ "not test_geocode_to_gdf"
+ " and not test_stats"
+ " and not test_osm_xml"
+ " and not test_elevation"
+ " and not test_routing"
+ " and not test_plots"
+ " and not test_find_nearest"
+ " and not test_api_endpoints"
+ " and not test_graph_save_load"
+ " and not test_graph_from_functions"
+ " and not test_geometries"))))
(propagated-inputs
(list python-folium
python-geopandas