summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-05-04 20:12:39 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 13:04:24 -0400
commit02995444dbe9861c32b6e2cdbfb7a7b2affe2c2b (patch)
tree69b708f6c758f87a0a837bd3569c4d40bda9ccd1 /gnu/packages/gl.scm
parent61a326442442f9b09911d35b3a3a48cf5335d7d7 (diff)
gnu: mesa: Fix hardware video decoding.
* gnu/packages/gl.scm (mesa): Fix hardware video decoding. [arguments]: Add -Dvideo-codecs to the #:configure-flags [native-search-paths]: Add VDPAU_DRIVER_PATH so libvdpau can find the drivers. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 6521170ebb..bfe56e9393 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -360,6 +360,10 @@ svga,swrast,virgl")))
;; Enable the Vulkan overlay layer on all architectures.
"-Dvulkan-layers=device-select,overlay"
+ ;; Enable the codecs that were built by default as part of the
+ ;; 21.3.x releases to avoid functionality regressions.
+ "-Dvideo-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc"
+
;; Also enable the tests.
"-Dbuild-tests=true"
@@ -511,6 +515,11 @@ svga,swrast,virgl")))
(string-append "\"" out "/lib/lib" layer-name ".so\"")))))))
(for-each fix-layer-path '("VkLayer_MESA_device_select"
"VkLayer_MESA_overlay"))))))))
+ (native-search-paths
+ (list (search-path-specification
+ ;; Ensure the Mesa VDPAU drivers can be found.
+ (variable "VDPAU_DRIVER_PATH")
+ (files '("lib/vdpau")))))
(home-page "https://mesa3d.org/")
(synopsis "OpenGL and Vulkan implementations")
(description "Mesa is a free implementation of the OpenGL and Vulkan