summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
commit839bb4616f13171a23ad7937bf57d0a01d61d42a (patch)
tree01de78a5ce973b9fb7ac0f9216d64f736f8e163d /gnu/packages/gl.scm
parent0357bbbcd850f9220078a62da3c30358b8983765 (diff)
parentef71e3290916583973724316e815cee840c1b6d8 (diff)
Merge remote-tracking branch 'origin/master' into staging.
With resolved conflicts in: gnu/packages/ibus.scm gnu/packages/image.scm gnu/packages/lisp.scm gnu/packages/virtualization.scm
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm31
1 files changed, 28 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 672a820686..fd69e6dbeb 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -64,7 +64,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
- #:use-module (guix build-system waf)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix gexp)
@@ -128,7 +127,7 @@ as ASCII text.")
(propagated-inputs
;; Headers from Mesa and GLU are needed.
(list glu mesa))
- (home-page "http://freeglut.sourceforge.net/")
+ (home-page "https://freeglut.sourceforge.net/")
(synopsis "Alternative to the OpenGL Utility Toolkit (GLUT)")
(description
"Freeglut is a completely Free/OpenSourced alternative to
@@ -799,6 +798,32 @@ Both GLX and EGL are supported, in any combination with OpenGL and OpenGL ES.")
license:x11
license:expat))))
+(define-public libopenglrecorder
+ (package
+ (name "libopenglrecorder")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Benau/libopenglrecorder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sfx2kdw2mca3mx4fnk1yy74pilp2i9npcpyj894qkngz5aaz2wl"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no test suite
+ (native-inputs (list pkg-config))
+ (inputs (list libjpeg-turbo))
+ (home-page "https://github.com/Benau/libopenglrecorder")
+ (synopsis "Async readback OpenGL frame buffer with audio recording")
+ (description
+ "libopenglrecorder is a library allowing optional async readback OpenGL
+frame buffer with optional audio recording. It will do video and audio
+encoding together.")
+ (license license:bsd-3)))
+
(define-public soil
(package
(name "soil")
@@ -923,7 +948,7 @@ and visualizations.")
(list libpng mesa zlib))
(arguments
`(#:tests? #f)) ; no tests
- (home-page "http://www.geuz.org/gl2ps/")
+ (home-page "https://www.geuz.org/gl2ps/")
(synopsis "OpenGL to PostScript printing library")
(description "GL2PS is a C library providing high quality vector
output for any OpenGL application. GL2PS uses sorting algorithms