summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-23 19:05:13 +0200
committerMarius Bakke <marius@gnu.org>2022-06-23 19:55:43 +0200
commit32c676bbcd756f13fb6a5b978e069db54d5914a6 (patch)
treef6a45e595982524722a1c4bd77e84e54d5dec660 /gnu/packages/gl.scm
parent3787f0d215dd0836907b2d9d5d40f4053792cc07 (diff)
gnu: libepoxy: Update to 1.5.10.
* gnu/packages/gl.scm (libepoxy): Update to 1.5.10. [source]: Switch to GIT-FETCH. [arguments]: Remove trailing #t and defunct bootstrap phase.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9f9f78b921..3a57af44a5 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -717,21 +717,19 @@ OpenGL graphics API.")
(define-public libepoxy
(package
(name "libepoxy")
- (version "1.5.5")
+ (version "1.5.10")
+ (home-page "https://github.com/anholt/libepoxy")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/anholt/libepoxy/releases/download/"
- version "/libepoxy-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0mh5bdgqfd8m4wj6jlvn4ac94sgfa8r6ish75ciwrhdw47dn65i6"))))
+ "0jw02bzdwynyrwsn5rhcacv92h9xx928j3xp436f8gdnwlyb5641"))))
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
- (delete 'bootstrap)
- (add-before
- 'configure 'patch-paths
+ (add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((python (assoc-ref inputs "python"))
(mesa (assoc-ref inputs "mesa")))
@@ -739,15 +737,13 @@ OpenGL graphics API.")
(("/usr/bin/env python") python))
(substitute* (find-files "." "\\.[ch]$")
(("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
- (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
- #t))))))
+ (("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))))))))
(build-system meson-build-system)
(native-inputs
(list pkg-config python))
(propagated-inputs
;; epoxy.pc: 'Requires.private: gl egl'
(list mesa))
- (home-page "https://github.com/anholt/libepoxy/")
(synopsis "Library for handling OpenGL function pointer management")
(description
"A library for handling OpenGL function pointer management.")