summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-14 20:16:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-18 01:16:03 +0100
commit6713e9cb7efbf68bdca2057d85e96b0f1e86c348 (patch)
tree791c576341a11804647c5afc41829231d96e6c70 /gnu/packages/gl.scm
parente1454e0e5f13f1722f3328cad263efe0ca30db6b (diff)
gnu: mesa: Enable Vulkan drivers for Intel and Radeon.
* gnu/packages/gl.scm (mesa)[arguments]: Add "--with-vulkan-drivers=intel,radeon" to configure-flags for x86_64-linux. [synopsis]: Mention Vulkan. [description]: Mention Vulkan. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index dddf50f064..1956f60e6e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -296,6 +296,13 @@ also known as DXTn or DXTC) for Mesa.")
;; are stuck at OpenGL 2.1 instead of OpenGL 3.0+.
"--enable-texture-float"
+ ;; Enable Vulkan on x86-64.
+ ,@(match (%current-system)
+ ("x86_64-linux"
+ '("--with-vulkan-drivers=intel,radeon"))
+ (_
+ '("")))
+
;; Also enable the tests.
"--enable-gallium-tests"
@@ -382,11 +389,11 @@ also known as DXTn or DXTC) for Mesa.")
(delete-duplicates inodes))
#t))))))
(home-page "https://mesa3d.org/")
- (synopsis "OpenGL implementation")
- (description "Mesa is a free implementation of the OpenGL specification -
-a system for rendering interactive 3D graphics. A variety of device drivers
-allows Mesa to be used in many different environments ranging from software
-emulation to complete hardware acceleration for modern GPUs.")
+ (synopsis "OpenGL and Vulkan implementations")
+ (description "Mesa is a free implementation of the OpenGL and Vulkan
+specifications - systems for rendering interactive 3D graphics. A variety of
+device drivers allows Mesa to be used in many different environments ranging
+from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
(define-public mesa-headers