summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
commit39162ee49b08ccbd032324dc057fbafe8809c8a8 (patch)
tree181e0602ceeaa24bc0dad75bbd554eb37bf5d81a /gnu/packages/gl.scm
parentb78891b0120c2e6f7752912d43bc59e18ed9c465 (diff)
gnu: extempore: Only build on x86_64.
* gnu/packages/algebra.scm (kiss-fft-for-extempore)[supported-systems]: Only build on x86_64. * gnu/packages/gl.scm (nanovg-for-extempore)[supported-systems]: Likewise. * gnu/packages/image.scm (stb-image-for-extempore)[supported-systems]: Likewise. * gnu/packages/llvm.scm (llvm-for-extempore)[supported-systems]: Likewise. * gnu/packages/music.scm (portmidi-for-extempore)[supported-systems]: Likewise. (extempore)[supported-systems]: Likewise.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 707e3d4d1d..a4ec3a3536 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -591,6 +591,8 @@ and surfaces, receiving input and events.")
(arguments `(#:tests? #f)) ; no tests included
(inputs
`(("mesa" ,mesa)))
+ ;; Extempore refuses to build on architectures other than x86_64
+ (supported-systems '("x86_64-linux"))
(home-page "https://github.com/extemporelang/nanovg")
(synopsis "2D vector drawing library on top of OpenGL")
(description "NanoVG is small antialiased vector graphics rendering