summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-30 12:01:32 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-30 12:05:27 +0200
commit79355ae3e84359716f5135cc7083e72246bc8bf9 (patch)
tree6b61851e2153581578bb78ef0f177b8841ee5db7 /gnu/packages/gl.scm
parent39d6b9c99f297e14fc4f47f002be3d40556726be (diff)
parent86d8f6d3efb8300a3354735cbf06be6c01e23243 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm31
1 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7014081eb2..ee56998da7 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -366,14 +367,14 @@ glxgears, glxheads, and glxinfo.")
(define-public glew
(package
(name "glew")
- (version "1.11.0")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/glew/glew/" version
"/glew-" version ".tgz"))
(sha256
(base32
- "1mhkllxz49l1x680dmzrv2i82qjrq017sykah3xc90f2d8qcxfv9"))
+ "0r37fg2s1f0jrvwh6c8cz5x6v4wqmhq42qm15cs9qs349q5c6wn5"))
(modules '((guix build utils)))
(snippet
'(substitute* "config/Makefile.linux"
@@ -582,3 +583,29 @@ OpenGL.")
desktop computers. It provides a simple API for creating windows, contexts
and surfaces, receiving input and events.")
(license license:zlib)))
+
+(define-public nanovg-for-extempore
+ (package
+ (name "nanovg-for-extempore")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/extemporelang/nanovg/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ivs1sagq19xiw8jxd9f8w2b39svi0n9hrbmdvckwvqg95r8701g"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("mesa" ,mesa)))
+ ;; Extempore refuses to build on architectures other than x86_64
+ (supported-systems '("x86_64-linux"))
+ (home-page "https://github.com/extemporelang/nanovg")
+ (synopsis "2D vector drawing library on top of OpenGL")
+ (description "NanoVG is small antialiased vector graphics rendering
+library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
+aimed to be a practical and fun toolset for building scalable user interfaces
+and visualizations.")
+ (license license:zlib)))