summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-04 21:27:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:38 -0400
commitb48162d3c98625a87b77da67578bbaa1843f693d (patch)
tree2b99471b9c178db12de4b207285ddbf1bbe8d2ea /gnu/packages/glib.scm
parent579facddec29ec47c0b1bd9c0489fcecdc758f4c (diff)
gnu: Add gobject-introspection-next.
* gnu/packages/glib.scm (gobject-introspection-next): New variable. * gnu/packages/patches/gobject-introspection-absolute-shlib-path-1.72.patch: New file. * gnu/packages/patches/gobject-introspection-cc-1.72.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 820a44cbde..32220ee69b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -546,6 +546,26 @@ provide bindings to call into the C library.")
;; For tools.
license:gpl2+))))
+(define-public gobject-introspection-next
+ (package
+ (inherit gobject-introspection)
+ (name "gobject-introspection")
+ (version "1.73.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/"
+ "gobject-introspection/" (version-major+minor version)
+ "/gobject-introspection-" version ".tar.xz"))
+ (sha256
+ (base32 "1gkbx32as3v2286w7k3j24fwhkxj6brr49881m2zavxamfwxdm34"))
+ (patches (search-patches
+ "gobject-introspection-cc-1.72.patch"
+ "gobject-introspection-girepository.patch"
+ "gobject-introspection-absolute-shlib-path-1.72.patch"))))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs gobject-introspection)
+ (replace "glib" glib-next)))))
+
(define intltool
(package
(name "intltool")