summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-20 22:12:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-20 22:12:49 +0100
commit1dba64079c5aaa1fb40e4b1d989f1f06efd6cb63 (patch)
treeaf5bb45a45bfe2b6ac7d9be4a314997fcd50958c /gnu/packages/glib.scm
parent953ab5030f1ee870944a291f9e8edc491b198969 (diff)
gnu: gettext: Rename binding to 'gnu-gettext'.
* gnu/packages/gettext.scm (gettext): Rename to... (gnu-gettext): ... this. This is used to work around the circular dependency introduced in commit c42a4b7, which users with a #:renamer cannot cope with. * gnu/packages/acl.scm, gnu/packages/attr.scm, gnu/packages/cdrom.scm, gnu/packages/fdisk.scm, gnu/packages/gkrellm.scm, gnu/packages/glib.scm, gnu/packages/gnunet.scm, gnu/packages/grub.scm, gnu/packages/linux.scm, gnu/packages/maths.scm, gnu/packages/nano.scm, gnu/packages/parted.scm, gnu/packages/system.scm, gnu/packages/version-control.scm, gnu/packages/vpn.scm, gnu/packages/w3m.scm, gnu/packages/wget.scm: Adjust accordingly.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 61ba0b944e..fc65f304fc 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -29,8 +29,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
- #:use-module ((gnu packages gettext)
- #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages perl)
@@ -124,7 +123,7 @@ shared NFS home directories.")
"doc")) ; 20 MiB of GTK-Doc reference
(inputs
`(("coreutils" ,coreutils)
- ("gettext" ,guix:gettext)
+ ("gettext" ,gnu-gettext)
("libffi" ,libffi)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
@@ -224,7 +223,7 @@ bindings to call into the C library.")
(propagated-inputs
`(;; Propagate gettext because users expect it to be there, and so does
;; the `intltool-update' script.
- ("gettext" ,guix:gettext)
+ ("gettext" ,gnu-gettext)
;; `file' is used by `intltool-update' too.
("file" ,file)