summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-12-10 09:43:29 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-12-10 14:25:34 +0100
commit6c2cf86edb04adb3a74bf4099fd9a8ad4f8c5ae1 (patch)
tree63bd1040e2eaf474ff99f33ef0934aba08f6c750 /gnu/packages/glib.scm
parentc7e553a30988d61197af2e1c9b79c2e684d76c8e (diff)
Revert "gnu: gobject-introspection: Update to 1.42.0 and add new patch."
This reverts commit 66717243d0683fa05b5630c2e011f3a486a8d316. Several packages fail to build with the new version.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 4f18ef7a88..486cdb6add 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -197,18 +197,17 @@ dynamic loading, and an object system.")
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.42.0")
+ (version "1.38.0")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
- "gobject-introspection/" (version-major+minor version)
- "/gobject-introspection-" version ".tar.xz"))
+ "gobject-introspection/"
+ (substring version 0 (string-rindex version #\.))
+ "/gobject-introspection-"
+ version ".tar.xz"))
(sha256
- (base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
- (patches (list
- (search-patch "gobject-introspection-cc.patch")
- (search-patch
- "gobject-introspection-absolute-shlib-path.patch")))))
+ (base32 "0wvxyvgajmms2bb6k3pf1rdpnd79xdxamykzvxzmcyn1ag9yax9m"))
+ (patches (list (search-patch "gobject-introspection-cc.patch")))))
(build-system gnu-build-system)
(inputs
`(("bison" ,bison)
@@ -229,10 +228,7 @@ dynamic loading, and an object system.")
(directories '("lib/girepository-1.0")))))
(search-paths native-search-paths)
(arguments
- `(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
- ;; some tests to fail.
- #:tests? #f
- #:phases
+ `(#:phases
(alist-cons-before
'configure 'patch-paths
(lambda _