summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-17 23:25:46 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-20 00:38:01 +0100
commit72b1f2d33522e6ef681a3d3ef1a370a9f415e989 (patch)
treef207b539915cc379c595bafb2bfd95dc09937aba /gnu/packages/gnome-xyz.scm
parent38d9f8c074059a0645aa54c72e25ebdeb04031b5 (diff)
gnu: gnome-shell-extension-just-perfection: Update to 26.0.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-just-perfection): Update to 26.0. [arguments]: Convert to list of G-Expressions. Change-Id: Ib02ab984310705bfa435ab1ea8d47c74a6162db0 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm59
1 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index db28f0a5d5..8501654419 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -906,7 +906,7 @@ currently focused application in the top panel of the GNOME shell.")
(define-public gnome-shell-extension-just-perfection
(package
(name "gnome-shell-extension-just-perfection")
- (version "22.0")
+ (version "26.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -915,36 +915,37 @@ currently focused application in the top panel of the GNOME shell.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r4rflppcp05kwhzmh07dzi7znc4kch4nc8mzw61arj3qsfq2qqj"))))
+ "0dvq2mb04b557g9nz4pm90x2c2jc1dwwbg2is1gkx38yk0dsj6r3"))))
(build-system copy-build-system)
(arguments
- `(#:install-plan
- '(("src"
- "share/gnome-shell/extensions/just-perfection-desktop@just-perfection"
- #:include-regexp ("\\.css$" "\\.compiled$" "\\.js(on)?$" "\\.ui$"))
- ("locale"
- "share/gnome-shell/extensions/just-perfection-desktop@just-perfection/"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'drop-executable-bits
- (lambda _
- (for-each
- (lambda (file)
- (let ((stat (lstat file)))
- (chmod file (logand (stat:mode stat) (lognot #o111)))))
- (find-files "." #:directories? #f))))
- (add-before 'install 'build
- (lambda _
- (invoke "glib-compile-schemas" "src/schemas")
- (for-each
- (lambda (file)
- (let* ((base (basename file))
- (noext (substring base 0 (- (string-length base) 3)))
- (dest (string-append "locale/" noext "/LC_MESSAGES/"))
- (out (string-append dest "just-perfection.mo")))
- (mkdir-p dest)
- (invoke "msgfmt" "-c" file "-o" out)))
- (find-files "po" "\\.po$")))))))
+ (list
+ #:install-plan
+ #~'(("src"
+ "share/gnome-shell/extensions/just-perfection-desktop@just-perfection"
+ #:include-regexp ("\\.css$" "\\.compiled$" "\\.js(on)?$" "\\.ui$"))
+ ("locale"
+ "share/gnome-shell/extensions/just-perfection-desktop@just-perfection/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'drop-executable-bits
+ (lambda _
+ (for-each
+ (lambda (file)
+ (let ((stat (lstat file)))
+ (chmod file (logand (stat:mode stat) (lognot #o111)))))
+ (find-files "." #:directories? #f))))
+ (add-before 'install 'build
+ (lambda _
+ (invoke "glib-compile-schemas" "src/schemas")
+ (for-each
+ (lambda (file)
+ (let* ((base (basename file))
+ (noext (substring base 0 (- (string-length base) 3)))
+ (dest (string-append "locale/" noext "/LC_MESSAGES/"))
+ (out (string-append dest "just-perfection.mo")))
+ (mkdir-p dest)
+ (invoke "msgfmt" "-c" file "-o" out)))
+ (find-files "po" "\\.po$")))))))
(native-inputs
(list `(,glib "bin") gettext-minimal))
(home-page "https://gitlab.gnome.org/jrahmatzadeh/just-perfection")