summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorTrevor Richards <trev@trevdev.ca>2022-09-21 17:20:35 -0700
committerLudovic Courtès <ludo@gnu.org>2022-09-28 23:20:45 +0200
commit0e367799869281c2cee8c7d563fd68f9e08c3fac (patch)
treef85ad2729e911e2f111a24c3eade146b606e50cb /gnu/packages/gnome-xyz.scm
parent48c938fbc7267cbb7f7d223cffee482b11c3b7d8 (diff)
gnu: Add gnome-shell-extension-unite-shell.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-unite-shell): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm41
1 files changed, 40 insertions, 1 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 34a703c7e1..68166978a1 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -69,7 +69,8 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages ruby)
#:use-module (gnu packages web)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
(define-public arc-icon-theme
(package
@@ -303,6 +304,44 @@ and products. Plots is designed to integrate well with the GNOME desktop and
takes advantage of modern hardware using OpenGL.")
(license license:gpl3+)))
+(define-public gnome-shell-extension-unite-shell
+ (package
+ (name "gnome-shell-extension-unite-shell")
+ (version "65")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hardpixel/unite-shell")
+ (commit "127edac6396b89cdedec003bdff38820e6a0f91f")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lzhf7hlvzg62nxjfpv265315qibcjz5dv08dzpfckf2dx68nab4"))))
+ (build-system copy-build-system)
+ (native-inputs (list `(,glib "bin") gettext-minimal))
+ (inputs (list xprop))
+ (arguments
+ (list #:install-plan ''(("./unite@hardpixel.eu"
+ "share/gnome-shell/extensions/unite@hardpixel.eu"))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-xprop-bin
+ (lambda _
+ (substitute* "unite@hardpixel.eu/window.js"
+ (("xprop")
+ (string-append #$(this-package-input "xprop")
+ "/bin/xprop")))))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "unite@hardpixel.eu/schemas"
+ (invoke "glib-compile-schemas" ".")))))))
+ (home-page "https://github.com/hardpixel/unite-shell")
+ (synopsis "Top panel and window decoration extension for GNOME Shell")
+ (description
+ "Unite is a GNOME Shell extension which makes a few layout
+tweaks to the top panel and removes window decorations to make it look like
+Ubuntu Unity Shell.")
+ (license license:gpl3)))
+
(define-public gnome-shell-extension-appindicator
(package
(name "gnome-shell-extension-appindicator")