summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-10-18 23:04:24 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-22 10:41:09 +0200
commit2902def73e3d9d671099cbbea7fcc59b12c10ec8 (patch)
tree69dd8b8b204d2b3f43c40ed2e3160b41057ee187 /gnu/packages/gnome-xyz.scm
parent863c228bfd53aac478eee46f6ee54d87fee9d764 (diff)
gnu: gnome-shell-extension-blur-my-shell: Update to 44.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): Update to 44. [source]: Remove snippet to delete compiled schemas. [arguments]<#:install-plan>: Update accordingly. <#:phases>: Remove ‘cd-src’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 68166978a1..b7e10100fb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -996,7 +996,7 @@ animation of closing windowed applications.")
(define-public gnome-shell-extension-blur-my-shell
(package
(name "gnome-shell-extension-blur-my-shell")
- (version "29")
+ (version "44")
(source
(origin
(method git-fetch)
@@ -1006,22 +1006,21 @@ animation of closing windowed applications.")
(file-name (git-file-name name version))
(sha256
(base32
- "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
- (snippet
- '(begin (delete-file "src/schemas/gschemas.compiled")))))
+ "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
(build-system copy-build-system)
(arguments
- `(#:install-plan
- '(("." ,(string-append
- "share/gnome-shell/extensions/"
- "blur-my-shell@aunetx")
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))
+ '(#:install-plan
+ (let ((extension "share/gnome-shell/extensions/blur-my-shell@aunetx"))
+ `(("src/" ,extension)
+ ("resources/" ,extension
+ #:include-regexp ("\\.svg$" "\\.ui"))
+ ("." ,extension
+ #:exclude-regexp ("src/" "resources/")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$"))))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'cd-src
- (lambda _ (chdir "src")))
- (add-before 'install 'compile-schemas
+ (add-after 'unpack 'compile-schemas
(lambda _
(with-directory-excursion "schemas"
(invoke "glib-compile-schemas" ".")))))))