summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2022-12-30 23:18:05 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-01 15:14:36 +0000
commitfbcc42ad6c22ef7257daede968ff2b8d41bdd30d (patch)
tree63a872e4a3af1bbd38c55889b34b037662693201 /gnu/packages/gnome-xyz.scm
parent4a15f2e2263e0bd43ea93bc3d81ce50f565b05cc (diff)
gnu: Add flat-remix-gnome-theme.
* gnu/packages/gnome-xyz.scm (flat-remix-gnome-theme): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index e43b19d69c..19838c3dd5 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -293,6 +293,33 @@ material design. It is mostly flat using a colorful palette with some
shadows, highlights, and gradients for some depth.")
(license license:gpl3+)))
+(define-public flat-remix-gnome-theme
+ (package
+ (name "flat-remix-gnome-theme")
+ (version "20221107-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/daniruiz/flat-remix-gnome")
+ ;; This commit adds GtkSourceView 5 theme, for GNOME Text Editor.
+ (commit "b5616efc515e9f1417436e67d94718db7529a2ba")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10fgdz8hz8rd7aj4vb3bvl8khzb2fvaia7n00gi0x19yvnnh36pr"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ `(("share" "/")
+ ("themes" "/share/"))))
+ (home-page "https://drasite.com/flat-remix-gnome")
+ (synopsis "GNOME shell theme with material design")
+ (description "Flat Remix GNOME is a GNOME shell theme inspired by material
+design. It is mostly flat using a colorful palette with some shadows,
+highlights, and gradients for some depth.")
+ (license license:gpl3+)))
+
(define-public gnome-plots
(package
(name "gnome-plots")