summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-18 19:19:02 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-20 00:38:12 +0100
commit1f9339fce4a81757fb18372aa974217d8e03c551 (patch)
treefc185a91fa133df3f03b531d05ac8604146c1f2f /gnu/packages/gnome-xyz.scm
parent3a0d32a155087d465ae5e6fd9425ef82706b2aa8 (diff)
gnu: Add gnome-shell-extension-v-shell.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-v-shell): New variable. Change-Id: Ib7e3cf5cffed621e2ccd54c84004c5ab8504fa9a Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 3775a6c54a..cf5d55f150 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1099,6 +1099,42 @@ store an history of everything you do, so that you can get back to older
copies you now want to paste.")
(license license:bsd-2)))
+(define-public gnome-shell-extension-v-shell
+ (package
+ (name "gnome-shell-extension-v-shell")
+ (version "37")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/G-dH/vertical-workspaces")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1h9f3g1dswxkka0yyj51610w86mwl46ylch19b51gj5mmxlyvzlv"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("." #$(string-append
+ "share/gnome-shell/extensions/"
+ "vertical-workspaces@G-dH.github.com")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$" "\\.gresource$")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'build
+ (lambda _
+ (invoke "make" "all"))))))
+ (native-inputs
+ (list gettext-minimal `(,glib "bin")))
+ (home-page "https://github.com/G-dH/vertical-workspaces")
+ (synopsis "Shell configuration with horizontal or vertical workspaces")
+ (description "V-Shell (Vertical Workspaces) lets the user configure different parts of the
+shell, including panels, corners, workspaces.")
+ (license license:gpl3)))
+
(define-public gnome-shell-extension-vertical-overview
(package
(name "gnome-shell-extension-vertical-overview")